Warning und Fatal error nach kopieren

Hallo, also ich habe den shop runterkopiert und jetzt wieder hochgeladen und jetzt bekomme ich nur noch das:


Warning: include(/etc/phpmyadmin/blowfish_secret.inc.php) [function.include]: failed to open stream: No such file or directory in /var/www/web244/html/snw/config.inc.php on line 62

Warning: include() [function.include]: Failed opening '/etc/phpmyadmin/blowfish_secret.inc.php' for inclusion (include_path='.:/usr/local/php5-cgi//lib/php') in /var/www/web244/html/snw/config.inc.php on line 62

Warning: include(/etc/phpmyadmin/config.inc.php) [function.include]: failed to open stream: No such file or directory in /var/www/web244/html/snw/config.inc.php on line 846

Warning: include() [function.include]: Failed opening '/etc/phpmyadmin/config.inc.php' for inclusion (include_path='.:/usr/local/php5-cgi//lib/php') in /var/www/web244/html/snw/config.inc.php on line 846

Warning: include_once(/var/www/web244/html/snw/core/adodblite/adodbSQL_drivers//_driver.inc) [function.include-once]: failed to open stream: No such file or directory in /var/www/web244/html/snw/core/adodblite/adodb.inc.php on line 53

Warning: include_once() [function.include]: Failed opening '/var/www/web244/html/snw/core/adodblite/adodbSQL_drivers//_driver.inc' for inclusion (include_path='.:/usr/local/php5-cgi//lib/php') in /var/www/web244/html/snw/core/adodblite/adodb.inc.php on line 53

Warning: include_once(/var/www/web244/html/snw/core/adodblite/adodbSQL_drivers//_meta_module.inc) [function.include-once]: failed to open stream: No such file or directory in /var/www/web244/html/snw/core/adodblite/adodb.inc.php on line 67

Warning: include_once() [function.include]: Failed opening '/var/www/web244/html/snw/core/adodblite/adodbSQL_drivers//_meta_module.inc' for inclusion (include_path='.:/usr/local/php5-cgi//lib/php') in /var/www/web244/html/snw/core/adodblite/adodb.inc.php on line 67

Warning: include_once(/var/www/web244/html/snw/core/adodblite/adodbSQL_drivers//_extend_module.inc) [function.include-once]: failed to open stream: No such file or directory in /var/www/web244/html/snw/core/adodblite/adodb.inc.php on line 67

Warning: include_once() [function.include]: Failed opening '/var/www/web244/html/snw/core/adodblite/adodbSQL_drivers//_extend_module.inc' for inclusion (include_path='.:/usr/local/php5-cgi//lib/php') in /var/www/web244/html/snw/core/adodblite/adodb.inc.php on line 67

Fatal error: Class '_extend_ADOConnection' not found in /var/www/web244/html/snw/core/adodblite/generic_modules/pear_module.inc(5) : eval()'d code on line 1

ich habe keine lust mehr bitte helft mir…

danke

Hallo redzero,

wo hast Du den Shop runterkopiert? War er eventuell schon lokal installiert?

Gruß
Marco

Hallo,

sorry, dass ich den alten Thread nochmal herauskrame. Ich habe aktuell die gleiche Fehlermeldung nach folgendem Vorgang, bisher keine Lösung dazu gefunden und bin ratlos.:

  • OXID-eShop CE Version 4.1.5 auf Server A (domainFACTORY) per SSH gepackt mit tar.gz
  • per wget auf Server B (ebenfalls dF) geholt und per SSH entpackt
  • DB per phpMyAdmin rüberkopiert
  • /tmp auf Server B geleert
  • config und htaccess für Server B angepasst.

Folgende Fehlermeldung:


Warning: include_once(/kunden/xxxxxxxxx/webseiten/temp-website-subdomain/xxxxxxx/core/adodblite/adodbSQL_drivers//_driver.inc) [function.include-once]: failed to open stream: No such file or directory in /kunden/xxxxxxxxx/webseiten/temp-website-subdomain/xxxxxxx/core/adodblite/adodb.inc.php on line 53

Warning: include_once() [function.include]: Failed opening '/kunden/xxxxxxxxx/webseiten/temp-website-subdomain/xxxxxxx/core/adodblite/adodbSQL_drivers//_driver.inc' for inclusion (include_path='.:/usr/local/lib/php') in /kunden/xxxxxxxxx/webseiten/temp-website-subdomain/xxxxxxx/core/adodblite/adodb.inc.php on line 53

Warning: include_once(/kunden/xxxxxxxxx/webseiten/temp-website-subdomain/xxxxxxx/core/adodblite/adodbSQL_drivers//_meta_module.inc) [function.include-once]: failed to open stream: No such file or directory in /kunden/xxxxxxxxx/webseiten/temp-website-subdomain/xxxxxxx/core/adodblite/adodb.inc.php on line 67

Warning: include_once() [function.include]: Failed opening '/kunden/xxxxxxxxx/webseiten/temp-website-subdomain/xxxxxxx/core/adodblite/adodbSQL_drivers//_meta_module.inc' for inclusion (include_path='.:/usr/local/lib/php') in /kunden/xxxxxxxxx/webseiten/temp-website-subdomain/xxxxxxx/core/adodblite/adodb.inc.php on line 67

Warning: include_once(/kunden/xxxxxxxxx/webseiten/temp-website-subdomain/xxxxxxx/core/adodblite/adodbSQL_drivers//_extend_module.inc) [function.include-once]: failed to open stream: No such file or directory in /kunden/xxxxxxxxx/webseiten/temp-website-subdomain/xxxxxxx/core/adodblite/adodb.inc.php on line 67

Warning: include_once() [function.include]: Failed opening '/kunden/xxxxxxxxx/webseiten/temp-website-subdomain/xxxxxxx/core/adodblite/adodbSQL_drivers//_extend_module.inc' for inclusion (include_path='.:/usr/local/lib/php') in /kunden/xxxxxxxxx/webseiten/temp-website-subdomain/xxxxxxx/core/adodblite/adodb.inc.php on line 67

Fatal error: Class '_extend_ADOConnection' not found in /kunden/xxxxxxxxx/webseiten/temp-website-subdomain/xxxxxxx/core/adodblite/generic_modules/pear_module.inc(5) : eval()'d code on line 1

Server B läuft ebenso wie Server A mit PHP 5.2.13 mit einer MySQL 5.1.60 DB. Das Setting dürfte identisch sein, da beides bei dF Managed Hosting ist. Die Installation soll testweise auf Server B auf aktuellen Stand gebracht.

Hat jemand eine Idee, woher das Problem mit den adodbSQL_drivers kommt?

Viele Grüße
Björn

Hallo Björn,

die Methode per tar.gz und wget habe ich bisher immer für die todsicherste gehalten - offenbar haben sich dennoch ein paar Dateien geweigert umzuziehen.
Ich tippe auf ein Rechteproblem: SSH ist ein anderer Benutzer als www-data.

Gruß

Hallo Marco,

vielen Dank für den Hinweis. Die Dateien wurden per SSH anscheinend nicht 1:1 gepackt. Über den “langen Weg” per FTP down-/upload im Binärmodus hat es dann doch geklappt.

Viele Grüße
Björn

rsync ist imho noch besser wie tarball :wink:
hatte ich am montag erst und hat ohne probleme geklappt :slight_smile:
OT: im mobiletemplate bekomm ich nach erfolgreichem login, den imho italienischen hinweis redirectonare :wink: