White screen on shop site after installation

Hi,

I just downloaded this shopping cart and installed it without any errors.

I can get into the admin area but when I try to access the shop I just get a white screen.

OXID runs here locally on a Mac OS 10.5.5 with MAMP 1.7.2

Thanx & Bye from Berlin

dogsch

Hi dogsch,

debugging a white screen is a bit hard, isn’t it? :wink:
You probably have your display_errors set to OFF. Please check your error.log and come up with the error message again.


Marco Steinhäuser
Community Operator
OXID eSales AG

I thought you have a cristal bowl :wink:

ok, I did it - here it was it says:

Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 4864 bytes) in /Applications/MAMP/htdocs/OXID_eshop/core/oxbasket.php on line 1790

Ah ok, here we go:

The memory_limit of your server is set to 8MB in php.ini. The Shop needs a bit more :wink:
Find the php.ini in your MAMP and set memory_limit to 16MB at least, recommended 30MB.


Marco Steinhäuser
Community Operator
OXID eSales AG

thanx !!!

Now I can play :wink:

Bye from the Hauptstadt

dogsch

Hello!

Today in installed the community version on an 32bit debian system, and also got a white screen after installation.

Error logging is activated (I assured that by inserting an temporary error in index.php :-))

There are no error entries, there is just a white page displayed (no HTML Source-Code in there).
Mod_rewrite is activated, .htaccess is allowed by (AllowOverwrite all) in the apache conf file.

When i try to access the page, I’m directly redirected to http://URL/index.php?cl=start&redirected=1
If i try to access http://URL/admin, i’m also redirected to http://URL/index.php?cl=start&redirected=1 and no login is displayed.

Any ideas or suggestions ?
Thanks in advance!

Chris

http://live.w00dy.info @work bei http://www.gugler.at

hi Chris,

I tried to investingate the problem localy, but still have no idea why it could happen in shop front end and in admin. Could you pls try to open config.inc.php file, set iDebug value to -1 and then try again, maybe then you see any PHP error message? I am personally interested, because this white screen is a situation what should not happen in any case…

Tomas

Hmm, the response does not seem unusual… But looking to your sql log I realized, that your installation was publicly accessible. Your EXCEPTION_LOG.txt file says:

2009-01-22 15:37:08exception ‘ADODB_Exception’ with message 'mysql error: [1227: Access denied; you need the SUPER privilege for this operation] in EXECUTE(“show innodb status”)

Could it be the reason causing the problem?

(And I would suggest to edit your post to remove your host information for future :slight_smile: )

Tomas

iDebug with -1 displays no error messages.

If is set iDebug to 7 then those errors appear:

About 30-40 times: Warning: file_get_contents(/home/users/fohringer/www/oxdebugdb_skipped.sql) []: failed to open stream: No such file or directory in /home/users/fohringer/www/core/oxdebugdb.php on line 40

MissingKeys: 0.000298 - select oxvarname, oxvartype, DECODE( oxvarvalue, ‘fq45QS09_fqyx09239QQ’) as oxvarvalue from oxconfig where oxshopid = ‘oxbaseshop’

Backtrace:
/home/users/fohringer/www/core/adodblite/adodb.inc.php - adodb_log_sql:313
/home/users/fohringer/www/core/oxconfig.php - Execute:483
/home/users/fohringer/www/core/oxconfig.php - _loadVarsFromDb:410
/home/users/fohringer/www/core/oxconfig.php - init:452
/home/users/fohringer/www/index.php - getInstance:78
[MissingKeys: 0.000263 -

select oxseourl, oxlang from oxseo where oxstdurl = ‘index.php?cl=start&redirected=1’ and oxlang = ‘0’ limit 1

Backtrace:
/home/users/fohringer/www/core/adodblite/adodb.inc.php - adodb_log_sql:313
/home/users/fohringer/www/core/oxseodecoder.php - Execute:327
/home/users/fohringer/www/views/oxubase.php - fetchSeoUrl:207
/home/users/fohringer/www/views/oxubase.php - _processRequest:234
/home/users/fohringer/www/views/start.php - init:111
/home/users/fohringer/www/views/oxshopcontrol.php - init:251
/home/users/fohringer/www/views/oxshopcontrol.php - _process:84
/home/users/fohringer/www/index.php - start:104
[url=]TRACE (show/hide)](]TRACE (show/hide)[/url)

MissingKeys: 0.000280 -

select oxvendor.oxid, oxvendor.oxshopid, oxvendor.oxactive, oxvendor.oxicon, oxvendor.oxtitle, oxvendor.oxshortdesc, oxvendor.oxshowsuffix from oxvendor where oxvendor.oxactive = 1 and oxvendor.oxtitle != ‘’ order by oxvendor.oxtitle

Backtrace:
/home/users/fohringer/www/core/adodblite/adodb.inc.php - adodb_log_sql:313
/home/users/fohringer/www/core/oxlist.php - Execute:398
/home/users/fohringer/www/core/oxvendorlist.php - selectString:105
/home/users/fohringer/www/core/oxvendorlist.php - loadVendorList:122
/home/users/fohringer/www/views/oxcmp_categories.php - buildVendorTree:148
/home/users/fohringer/www/views/oxcmp_categories.php - _loadVendorTree:98
/home/users/fohringer/www/views/oxview.php - init:374
/home/users/fohringer/www/views/oxubase.php - init:249
/home/users/fohringer/www/views/start.php - init:111
/home/users/fohringer/www/views/oxshopcontrol.php - init:251
/home/users/fohringer/www/views/oxshopcontrol.php - _process:84
/home/users/fohringer/www/index.php - start:104
[MissingKeys: 0.000254 -

select * from oxcontents where oxactive = ‘1’ and oxtype = ‘2’ and oxsnippet = ‘0’ and oxshopid = ‘oxbaseshop’ and oxcatid is not null order by oxloadid

Backtrace:
/home/users/fohringer/www/core/adodblite/adodb.inc.php - adodb_log_sql:313
/home/users/fohringer/www/core/oxlist.php - Execute:398
/home/users/fohringer/www/core/oxcontentlist.php - selectString:89
/home/users/fohringer/www/core/oxcontentlist.php - _loadMenue:60
/home/users/fohringer/www/core/oxcategorylist.php - loadCatMenues:349
/home/users/fohringer/www/core/oxcategorylist.php - _ppAddContentCategories:190
/home/users/fohringer/www/views/oxcmp_categories.php - buildTree:126
/home/users/fohringer/www/views/oxcmp_categories.php - _loadCategoryTree:102
/home/users/fohringer/www/views/oxview.php - init:374
/home/users/fohringer/www/views/oxubase.php - init:249
/home/users/fohringer/www/views/start.php - init:111
/home/users/fohringer/www/views/oxshopcontrol.php - init:251
/home/users/fohringer/www/views/oxshopcontrol.php - _process:84
/home/users/fohringer/www/index.php - start:104
[url=]TRACE (show/hide)](]TRACE (show/hide)[/url)

…and so on…

http://live.w00dy.info @work bei http://www.gugler.at

As this is just a testserver, the host info is not that great problem :slight_smile:

The error with the SUPER Privilege was already solved, I’ve installed it now 4-5 times, with root mysql privileges, without root privileges, with demo data and without…

I just deleted the whole content, uploaded the zip and unzipped it in a ssh console.
So it worked out of the box.

Unzipping local and uploading it per WebDav did not work.

Greetz from Austria,

Chris

http://live.w00dy.info @work bei http://www.gugler.at