Automatische Zoom-Funktion deaktivieren

Hallo!!!

Ich habe mir das eben mal angesehen und abgeändert. Nun entscheidet der Kunde (also der Admin), welches Bild als Zoom kommt und welches nicht. s.Bild.

Grüße

Cutty

Moin Cutty,

so weit so schön. Wie bekomme ich das denn nun hin, dass es ein drittes Zoombild #3 gibt, aber das System nicht automatisch auch ein Detailbild davon ab-/anlegt?

Hallo!!!

Na, da könnte man eine 2 Spalte anlegen und von Grund auf bestimmen, als was das Bild verwendet wird. Das mach ich aber morgen,

Grüße

Cutty

Hallo!!!

Nun geht´s mit allen Bildern, d.h. man kann sich nun aussuchen, welche Bilder als normale Pics erscheinen und welche als Zoombilder fungieren. Man kann so auch Bilder “stilllegen”, ohne sie löschen zu müssen.

In Kürze in unserem neuen Demoshop zu sehen: http://www.zahnsuche.de

Grüße

Cutty

Moin,

das man es als “Modul” programmieren kann, steht ausser Frage, aber ist halt nicht mit Boardmitteln realisierbar :wink: es wird was nachgebaut, was vorher da war … aber ich denke, die Kollegen von OXID werden sich da bestimmt was einfallen lassen …

Hallo!!!

nö, das ist kein Modul. Es bedarf nämlich nur der Anpassung von 2. Dateien.

Dann klappt`s auch mit dem Nachbarn :wink:

Grüße

Cutty

Hi,

nach sehr langer Zeit muss ich jetzt doch auch mal wieder schreiben - und gleich kräftig Motzen.

Ich sitze hier nämlich seit über 3 Stunden (Zeit die ich wirklich nicht habe) und frage mich was ich einem Kunden raten soll, der einfach nur die Bilder für neue Produkte hochladen will.

Das mit den Zoom-Bildern ist eine Sache, wie das Ding insgesamt funktioniert, oder eben nicht, eine andere.

Das nach zwei Wochen die Funktion im OXID eigenen Demo-Shop immer noch nicht funkt gibt einem ja bereits ‘Rätsel’ auf. Wenn ich mir den Source anschaue und in article_pictures::save() sehe, dass $this->_deleteMasterPicture( $oArticle, $iIndex ); mit einer nicht gesetzten Variable aufgerufen wird, kommen mir die nächsten Zweifel.

Der nächste Schub an Kopfschmerzen entsteht, wenn ich versuche mir einen Reim auf die Bilddatei-Namen (1)(2)… zu machen, welche entstehen wenn für einen Artikel Bilder mehrmals hochgeladen werden (die entstehen natürlich dadurch, weil der Dateiname bereits besteht - nur sollten sicher nicht mehr und mehr Dateien geschrieben werden, obwohl die ‘alten’ ja gar nicht mehr benötigt werden).

Endgültig schwach wird mir aber, wenn ich auf meinem eigenen Demo-Shop wiederholt ein paar Bilder hochlade und mir dann in den Bilder-Verzeichnissen anschaue, was dort dabei für ein unglaublicher Datenmüll entsteht (besonders schön, da ich die Bilder-Aufräum-Funktion der Version 3 auch nicht mehr finden kann).

Leute, bei aller Liebe zu OXID und zum Shop - so geht das doch wirklich nicht. Da wird ein immenser Aufwand in Unit Tests etc etc gesteckt - und dann kommt sowas zum Release. Gibt es denn keinen vernünftigen Tester, der (insbesondere) neue Features vor dem Release auch noch mit gesundem Menschenverstand unabhängig von Unit-Tests oder anderen automatischen Tests manuell gründlich durchprüft ??? Irgend jemand muss doch da mal was unternehmen, dass sowas nicht nochmal vorkommt.

Ich habe gehört, dass bis zum Monatsende Version 4.3.1 released werden soll. Meine einzige Hoffnung momentan ist, dass bis dahin das Problem irgendwie beseitigt wurde.

Glaube jetzt brauche ich erstmal einen Spaziergang um meine Nerven zu beruhigen. Danach muss ich mir noch überlegen was ich unserem Kunden schreibe (und was ich mit den anderen Shops mache die noch diesen Monat für die Umstellung auf 4.3.0 geplant waren), und dann muss ich irgendwann mit der Arbeit weiter machen, die ich vor 3.5 Stunden unterbrochen hatte …

Cheers,
Frank

greife hier nochmal das bildermanagement auf. ist es richtig, daß wenn man einen älteren artikel bearbeiten will, man erst alle bilddaten im admin löschen muß bevor man neue hochladen kann ??

früher konnt man einfach “überspeichern” jetzt mit der 4.3. ändert sich leider das zoom nur dann wenn man vorher alle altdaten löscht.

bug oder gewollt ??

juhu, endlich gibts nen bugeintrag dazu
https://bugs.oxid-esales.com/view.php?id=1807

Das scheint aber nicht der Fehler zu sein, der oben besporchen wird.

aber auch, normal müßten da mehrere bugmeldungen stehen, denn

  • vorschaubilder verschwinden wenn man von altversionen updatet
  • varianten erhalten kein eigenes bild
  • und noch einiges mehr
    wie z.b. bildnamen werden vom system umbenannt

Hallo zusammen,

ich muss da jetzt mal eine blöde Frage einwerfen. Wieso werden die zoom-Bildeinträge unter dem Artikel-Bilder-Reiter nicht mehr gezeigt (war bei Version 4.1.6 noch so)???
Es gibt sicher noch andere Betreiber (wie mich), die die Bilder lieber außerhalb des Shops generieren und hoch laden. Dabei ist es unter Umständen hilfreich, wenn man auch mal einfach ein 2., 3., 4., … zoom-Bild zusätzlich zeigt, ohne dafür ein Artikelbild, Thumb und Icon haben zu müssen.
Oder?

mach doch einfach nen bugeintrag - mein englisch ist dafür leider nicht zu gebrauchen und mit deutsch wäre ich längst gesperrt :wink:

[QUOTE=laramarco;32074]mach doch einfach nen bugeintrag - mein englisch ist dafür leider nicht zu gebrauchen und mit deutsch wäre ich längst gesperrt ;)[/QUOTE]

Da isser:
https://bugs.oxid-esales.com/view.php?id=1852

[QUOTE=upaffrath;32083]Da isser:
https://bugs.oxid-esales.com/view.php?id=1852[/QUOTE]

Resolution no change required
Status resolved

Nur leider abgelehnt!

[QUOTE=Firefax;32095]Resolution no change required
Status resolved

Nur leider abgelehnt![/QUOTE]

Ja, hab’s gerade erfahren - ich versteh’s echt nicht - das Ganze ist doch hirnrissig. Ich brauche keine 10 großen Bilder + 3 dazugehörige kleinere. Sondern ich brauche einen kompletten Satz (Icon, Thumb, Artikelbild, Zomm) + weitere Zooms. Bisher ging das. Jetzt geht es nicht mehr. Da die Bildeinträge in der Datenbank stehen, sollte es ja nicht die Hürde sein, wie bisher auch einen direkten Zugriff auf diese zu ermöglichen. Alles andere ist Gängelei

zum kotzen wenn alles abgelehnt wird - sorry muß ich echt auch sagen

früher konnte man bei mir direkt im artikel detail sehen, daß es weitere bilder gibt


jetzt muß man erst zoom klicken um zu sehen da is ja noch was

nur 2 beispiele von vielen und dabei sollte doch immer der kunde so schnell wie möglich auf jedes detail hingewiesen werden.

du hast jetzt noch andere probleme, jedenfalls find ich diese artikelverwaltung wie sie derzeit ist, never optimal

und immer noch nicht gehn varianten bilder - wird der bug auch wieder abgelehnt ???

Hallo,

ich hab mir die ganze Geschichte jetzt nochmal angeschaut: Frische 4.3.2, auf der VMware installiert (im Demoshop ist der Bildupload natürlich deaktiviert) und los geht’s:

Ich lade zu einem Produkt neue Basis-Bilder hoch: #1, #2 und #3. Aus meinem Basis-Bild werden Zoom-Bild, Normale Größe für die Detailseite und die drei Vorschaubilder auf der Detailseite generiert. Wenn ich möchte, kann ich statt #1 ein alternatives Thumbnail oder Icon generieren.
Nun lege ich mir eine Variante an und aktiviere sie, ohne Bilder zur Variante hinzuzufügen. Die Bilder des Vaterartikels werden vererbt und erscheinen nach dem ersten Aufruf der Detailseite der Variante auch als Thumbnail und Icon. Im Admin-Bereich der Variante sieht man diese vererbten Bilder nicht.
Wenn ich statt dessen andere Bilder in der Variante anzeigen lassen möchte, lade ich diese anderen Bilder hoch und bekomme diese angezeigt.

Sieht für mich erstmal ok aus. Was nicht heisst, dass der gewöhnliche Shopbetreiber das toll findet. Ich möchte bitte - am besten dieses Mal ohne Polemik - erklärt bekommen, wer sich welches Verfahren warum anders wünscht.

Danke und Gruß

bei einer Neuinstallation vielleicht Marco

aber jeder Updater kann DAS so nicht machen - sprich wenn ich bei mir neue Artikel anlege, so wie Du hier auch beschrieben hast, werden alle Bilder korrekt geladen.

ABER bei keiner einzigen Änderung eines Altartikels - es fehlen die zooms, es fehlen die Variantenbilder und NUR wenn man alle Artikel neu aufruft tut sich was. Ähm ich ruf doch net 10.000 Artikel/Varianten auf und speicher die Bilder neu.

Meiner Meinung nach fehlt da irgendwas im Update, daß die Altbilddaten zu Eurer jetzigen Handhabung “umformatiert”. (also das ist das was mir auffiel und betrifft direktes Adminarbeiten, lt. dem Thread gehts aber auch um externen Import, da halt ich mich raus)

Ok, da kann man ohne grossartige Einreichungen und Handstände Abhilfe schaffen: Man rutscht einfach einmal mit einem Crawler über den kompletten Shop, z.B. GSiteCrawler. Das ist zwar jetzt nicht die ganz professionelle Lösung, schafft aber eine schnelle Abhilfe. Weiter?