CKEditor-Modul fertig und ab sofort kaufbar!


#21

wo kann man den editor kaufen. danke für eine rückantwort.
bester gruß vom schönen niederrhein


#22

wo kann man den editor kaufen??? danke für die rückantwort.
bester gruß vom niederrhein


#23

Tja, ich hoffe mal, der eXchange wird in Kürze wieder sauber laufen, und werde dann auch die Links hier anpassen. Leider ist dort wg. Umbauarbeiten gerade einiges im Argen. Bis dahin kann das Modul aber jederzeit bei mir direkt bestellt werden (der eigene Shop ist leider noch nicht ganz fertig). Einfach per PM melden, dann kriegen wir das schon hin… :wink:


#24

wie kann ich den cke-ditor bei dir kaufen???
danke für deine bemühungen.
bester gruß vom niederrhein


#25

Schau doch einfach mal in deine privaten Nachrichten (PN oder PM wg. engl.)… :wink:


#26

[QUOTE=Mitmacher;89568]Einfach per PM melden, dann kriegen wir das schon hin… ;)[/QUOTE]

Klick mal auf das grüne Männchensymbol neben dem Usernamen von Mitmacher, dann klappt ein kleines Menü auf und in dem wählst Du dann “Private Nachricht an Mitmacher schicken” - das öffnet dann einen Editor, wo Du ihm eine PM (Private Message) senden kannst mit Deiner Anfrage und am besten noch mit Deinen Kontaktdaten.


#27

Yep, schöner hätte es man nicht beschreiben können, thx Hebsacker! :slight_smile:


#28

Na dafür hält sich Ray doch auch einen Stall von Ghostwritern… :smiley:


#29

Hallo

ich habe den Editor gekauft und erfolgreich installiert. Leider funktioniert er im Ineternetexplorer 9 unter Windows7 nicht. Dort wo das Textfeld mit dem Editor stehen soll, bekomme ich nur einen weißen Bildschirm. Nichteinmal das ursprüngliche Textfeld ist zu sehen


#30

@jason:
Stimmt, ist ja der Hammer, ich danke Dir fürs Feedback!
CKE läuft aber eigentlich problemfrei unter IE 9, auch mit allen meinen Ergänzungen (Ich habe den auch in eigenen CMS im Einsatz). Ich bin dem Fehler aber schon auf der Spur. Auf die Schnelle hilft es, in der admin/ckeditor/custom/config.js die “dialogDefinition” von Zeile 118-130 auszukommentieren, der Teil ist eh nur leichte Kosmetik. Danach klappte es bei mir auch im IE. Ist halt nur komisch, dass derselbe Code im CMS funzt und in Oxid nicht. Das versuche ich noch zu verstehen… :wink:

Gruß
Sascha

Edit: es bleibt zwar unklar, warum es nur mit Oxid nicht ging, aber hier mal die endgültige Lösung. Man ersetzt in der erwähnten config.js folgende Zeilen:

		oTab.get('txtBorder').default = '';
		oTab.get('txtWidth').default = '';
		oTab.get('txtCellSpace').default = 1;
		oTab.get('txtCellPad').default = 1;

durch diese:

		oTab.get('txtBorder')['default'] = '';
		oTab.get('txtWidth')['default'] = '';
		oTab.get('txtCellSpace')['default'] = 1;
		oTab.get('txtCellPad')['default'] = 1;

(oder man sucht und ersetzt einfach “.default” mit “[‘default’]”)
Es folgt in Kürze auch ein Modul-Update dafür…


#31

So, hat ein Weilchen gedauert, aber nun ist endlich die aktuellste CKE-Version 1.0.2 online (die Links im Eingangsthread sind auch angepasst)!

Ich hatte mich eine zeitlang daran versucht, diese Medienpfad-Problematik eleganter per <base href="…"> zu lösen, aber das hakt einfach zu sehr, wenn man auch Anker einsetzt. Also bleibt es beim bewährten “dirfix”, aber das habe ich nun als eigenes Modul gepackt, da man es erstens wohl selten braucht und zweitens so besser getrennt installieren und nutzen kann, gerade ab OXID 4.6.0.


#32

Hallo

einer meiner Kunden benutzt den Editor in Holland.
Leider ist dort der Editor nicht sichtbar. Es erscheint nur ein weißes Feld.
Hat der Editor eine automatische Spracherkennung (Hollandische Sprache ist ja nicht vorhanden), so daß dort nichts angezeigt wird?

Wenn ja, wie kann ich diese deaktivieren?


#33

Hi,

ich kann den Fehler zwar leider nicht reproduzieren, wahrscheinlich, da ich eben kein niederländisches Windows habe und tatsächlich wohl eine Auto-Sprach-Erkennung im CKE integriert ist. Aber man kann ja einfach die Sprachdateien aus dem offiziellen CKE-Paket nach /admin/ckeditor/lang kopieren, dann könnte es evtl. schon laufen (Anhang: bitte testen, würde mich auch interessieren!).

Die Sprachen hatte ich etwas “entrümpelt”, da ich den Bedarf nicht sah, alles drinzulassen. Wo bekommt man denn bitte z.b. funktionierende, d.h. vollständige Sprachpakete für Nederlands? Ich kann mir nicht vorstellen, dass sich jmd. eigenhändig die Mühe des Übersetzens macht, oder wie läuft das?

Grüße


#34

Hallo

ich habe nun die DE Sprachdatei kopiert, in nl.js umbenannt, in der Datei “DE” durch “NL” ersetzt und nun funktioniert es!


#35

Prima, danke fürs Feedback!
Warum aber so “kompliziert”? Nimm doch einfach die Anhang-Datei aus meinem letzten Post, damit geht es ohne weitere Eingriffe und vor allem auch niederländisch, was ja gewollt war, dachte ich? :wink:

Jedenfalls habe ich noch einen kleinen Denkfehler im CKE, wie ich gerade feststellte. Man kann nämlich natürlich diese Auto-Sprach-Erkennung auch übergehen, was im OXID-Admin wohl mehr Sinn macht (CKE sollte immer dieselbe Sprache wie der restliche Admin nutzen). Da bin ich gerade am Ändern und schnüre in Bälde ein weiteres Update. Wenn ich Deine Käuferdaten (vor allem e-Mail) kurz per PM bekomme, schicke ich Dir (und natürlich jedem weiterem Käufer) die Updates kostenfrei per Mail…


#36

So, liebe Leute, Version 1.0.3 ist online im eXchange. Das Paket ist nun fast doppelt so groß, da ich doch lieber alle Sprachdateien für CKE, dessen Plugins und KCF drin lasse (wer weiß, wer das doch mal braucht)… :wink:

Weiterhin habe ich die Synchronisation der GUI-Sprachen optimiert, sodass der CKE nun immer dieselbe Sprache nutzt, wie sie beim Backend-Login gewählt wurde. Dafür wird die Rechtschreibprüfung SCAYT nun immer auf die aktuelle Spracheinstellung des Artikels/Texts voreingestellt. Somit kann sich nun auch ein User z.b. in den Niederlanden englisch im Admin anmelden und einen deutschen Artikel bearbeiten, oder wie auch immer. Sorry, dass ich das bisher übersehen hatte und danke nochmal an jason_kx!

Es gilt für alle bisherigen Käufer:
Updates gibt es kostenfrei per Mail, wenn man per PM nachfragt und seine (Mail-)Adresse bestätigt.

Ach ja, das dirfix-Modul habe ich wieder reintegriert, da es einzeln mehr verwirrte. :wink:


#37

Hallo,

ich habe noch einen BUG entdeckt.
Auf Bildschirmen mit einer kleinen Auflösung z.B. 1280 x 768 wird das Fenster für den
Bilderupload so beschnitten, daß man nicht mehr auf den “OK” Button drücken kann.
Kann man den Editor so abändern, daß das Bilderupload Popup auch über den grauen Bereich hinüber geht?

UPDATE:
Es liegt wohl daran, daß die Seite “CMS-Seiten” in 2 Frames aufgeteilt ist und somit das Popup nicht über
den oberen Frame rübergeht.


#38

Es liegt wohl daran, daß die Seite “CMS-Seiten” in 2 Frames aufgeteilt ist und somit das Popup nicht über den oberen Frame rübergeht.

Genau, das stimmt (leider). Deswegen lasse ich es auch nicht als “BUG” gelten! :wink:
Aber folgender Tipp mag helfen (bis mir etwas besseres einfällt):
Statt “OK” geht man in irgendein Textfeld (z.b. URL) und drückt einfach <Return>, das hat denselben Effekt. Übrigens ist mir das schon länger bekannt und nervt mich auch, obwohl mein Monitor größer ist. Aber surfen im Vollbildmodus tue ich nie, weil ist irgendwie unpraktisch… :wink:
Jedenfalls fiel mir auf die Schnelle nie ein, wie man die Upload-Dialoge nur per config angepasst bekommt. Wenn man wieder mehr Zeit ist, schaue ich mir das aber nochmal in Ruhe an. Irgendwie geht das bestimmt.


#39

Hallo Mitmacher,

Modul gerade gekauft, installiert und bin begeistert.

Kurze Frage: durchgestrichen wird in der Menüleiste angeboten, nicht aber unterstrichen. Kann man das selbst konfigurieren?


#40

Modul gerade gekauft, installiert und bin begeistert.

Danke, das hört man gerne! :slight_smile:

Kurze Frage: durchgestrichen wird in der Menüleiste angeboten, nicht aber unterstrichen. Kann man das selbst konfigurieren?

Ja, das geht alles im Detail per Anpassung der /admin/ckeditor/custom/config.js auf mehrere Arten. Du könntest z.b. einfach config.toolbar_custom durch ‘Underline’, ergänzen (vor ‘Strike’). Allerdings lass mich kurz meinen Grund erklären, warum ich es absichtlich entfernt habe: die Verwechslungsgefahr mit Links ist einfach zu groß, gutes Webdesign nutzt imho meistens unterstrichene Links in Fließtexten. Das hängt natürlich vom Design (und auch Geschmack) ab, ob es in OXID ein Problem wäre oder nicht, und evtl. habe ich es auch etwas zu gut gemeint. Persönlich nutze ich aber möglichst [B]nie[/B] Unterstreichungen, wenn es eben kein Link ist, bin da wohl Nostalgiker.

Wie auch immer, man muss aber etwas aufpassen, sich bei zukünftigen Modul-Updates nicht seine config.js wieder zu “zerschießen”, von daher, am besten gut merken, was wo geändert wurde! :wink: