CKEditor-Modul fertig und ab sofort kaufbar!


#81

@sirc:
Danke für die Blumen, so einen Beitrag verdrängt man ungern als Schlusswort! :smiley:

Aber es hilft leider nichts, da ich kurz die neue Version 1.2.1 announcen will:
Dort habe ich nun die ältere Version 1.0.4 quasi mit integriert, also ab sofort wieder nur ein Modul für alle OXID-Versionen (seit 4.4)! Weiterhin wurde der CKE auf Version 4.1.1 aktualisiert (was man ja auch selbst machen kann), und eine neue Moduloption eingeführt, mit der man den Editor auch für weitere externe Module aktivieren kann. Zwei davon werden in Kürze im eXchange erhältlich sein… :slight_smile:


#82

Wichtige Mitteilung!

Mir wurde leider erst kürzlich ein Fehler im Editor gemeldet, der mich darauf brachte, dass die CKE Versionen ab 4.1 nicht mehr 100% kompatibel zu meinem Modul sind. Im Prinzip funktionieren sie zwar, aber einige Funktionen eben nicht mehr (z.b. alignment), und der Code wird teilweise etwas falsch bereinigt. Es tut mir leid, dass mir dieser Umstand nicht vorher auffiel, und ich habe sofort ein Update geschnürt (1.2.2), welches wieder den älteren CKE 4.0.3 enthält. Der funktioniert ja reibungslos, mind. bis ich eine Lösung für die neueren CKEs habe… :o

Sorry und beste Grüße!


#83

hi,
ist es moeglich in diesen modul die “Code bereinigung” abzuschalten ?
der editor ist zwar schoen und funktioniert teilweise gut…
diese nervige “Code bereinigung” zerstoert das ganze design der seite
da das ding html5 anscheinend nicht versteht

zb. wenn ich einen “a” tag um einen block element erstelle wandelt dieser editor den a tag um
so das ich mehere “a” tags am ende hab und das um jeden inline element

und wenn ich das im quelltext modus reinschreib kann ich auch nicht dierekt so speichern sondern muss erst wieder aus dem quelltext modus wieder raus, und wenn ich das mache dann wird der code “bereinigt”

ich hoffe es gibt hierfuer eine loesung ohne das ich das komplette design wieder umbauen muss

danke schon mal im vorraus


#84

Hi,

ist es moeglich in diesen modul die “Code bereinigung” abzuschalten ?

pauschal leider nein, aber man könnte sie noch “verstärken” (d.h. evtl. verschlimmern)… :wink:
Generell macht die Bereinigung aus CMS-Sicht natürlich schon Sinn, und der neue ACF-Mode (advanced content filter) ist auch klasse, aber wahrscheinlich muss man im Shop doch flexibler sein ab und zu. HTML5-tauglich ist es eigentlich schon, da habe ich mit “<br>” statt “<br />” u.ä. sogar noch nachgeholfen. Aber ehrlich gesagt, war es mir bis eben neu, dass man <blocks> mit <a> wrappen darf. Ich wüsste auch gerade nicht, wozu man das konkret braucht, oder ob man es nicht lieber anders lösen könnte/sollte, auch um evtl. abwärtskompatibel zu bleiben. Aber:

ich hoffe es gibt hierfuer eine loesung ohne das ich das komplette design wieder umbauen muss

ist natürlich auch ein Argument, klar. Ich weiß also nicht, wie man es am besten löst, aber ich sollte in die nächste Modulversion evtl. mal einen temporären Editor-Abschalter einbauen für bestimmte “Problem-Texte”. Das wäre aber eigentlich auch nur eine Krücke, vor allem, wenn viele Texte betroffen sind. Weitere Ideen sind also immer willkommen… :slight_smile:

Grüße

PS: ansonsten ist übrigens seit kurzem die neue Version 1.3.0 fertig und online. Dort ist der CKE 4.3 integriert und einige weitere Admin-Optionen, um bestimmte Sonder-Bereinigungen zu steuern.


#85

Hallo Leute,
ich habe mal wieder ein Modul-Update anzubieten (1.3.1), welches nun eine Option beinhaltet, den Editor für einzelne Elemente dauerhaft zu deaktivieren (lässt sich auch wieder rückgängig machen). Somit hat man eine Notlösung parat für ganz spezielle Inhalte, die ansonsten evtl. kaputt-bereinigt würden… :wink:

Dies ist und bleibt aber eine Krücke, und ich möchte zu dem Thema HTML-Bereinigung mal auf diese Beiträge eines CKE-Entwicklers verweisen (jeweils der letzte Beitrag von Reinmar):
http://ckeditor.com/forums/Support/Disable-HTML-correction
http://stackoverflow.com/questions/18363850/ckeditor-disable-auto-editing-html-code

Ich finde, viel besser kann man es nicht auf den Punkt bringen: es gibt klare Beschränkungen, wofür ein Wysiwyg-Editor taugt und überhaupt da ist. Und wenn man sich damit arrangiert, kann es ein gutes Hilfsmittel sein. Auf die Entscheidung habe ich jedoch keinerlei Einfluss.


#86

Hallo

Ich habe ein Problem mit diesem Modul. Ich habe aktuell die Version 4.9.3 installiert und heute die neue Version vom Editor gekauft. Das installieren klappt wunderbar und nachdem ich aktivieren geklickt habe, ist der Editor auch aktiv. Leider nur so lange bis ich einen Datensatz anwähle.

Das bedeutet, ich aktivieren den Editor, klicke dann z.B. auf CMS-Seiten, dann sehe ich den Editor im unterenbereich, sobald ich nun einen Datensatz anwähle z.B. AGB’s, dann wird der Editor deaktiviert und ich muss das Modul wieder aktivieren. Allerdings kriege ich keine Fehlermeldung, nichts …

Hat jemand eine Idee?

Vielen Dank!

Gruss Aurelio


#87

Hi Aurelio,

in dieser Form ist mir kein Fehler bekannt und es klingt nach einem individuellen Szenario. Ich schicke dir gerade mal eine Mail, damit wir das effizienter klären können… :slight_smile:


#88

Hi @all,

es gibt nun doch ein neues Modul-Update im eXchange, da ich heute auf einen kleinen Bug stieß, den ich sogleich behoben habe. Dies betraf jedoch nur die Version 1.4.1 und hatte auch nicht mit dem Problem von Aurelio zu tun (das löste sich quasi von alleine).
Außerdem ist natürlich auch wieder der aktuelle CKEditor an Board und eine neues optionales Feature namens “autogrow” (man ahnt den Zweck)… :slight_smile:

Weiterhin viel Spaß beim Wysiwygen!

PS: alle Update-betroffenen habe ich bereits direkt kontaktiert (die 1.4.1 war ja nur wenige Tage verfügbar).


#89

Irgendwie funktioniert der Editor bei mir nicht.
Ich kann
-keine Zeichensätze
-keine Formate
-keine Schriftgrößen
auswählen, da die entsprechenden Schaltflächen fehlen.
:confused:Vielleicht kann ich hier einen Ratschlag bekommen.

Danke: Theo


#90

Hi Theo,
so wie du es schreibst, habe ich den Verdacht, es ist dasselbe (alte) Missverständnis, welches ich bereits vor einigen Posts versucht habe zu erläutern (01-08-2014). So ein Wysiwyg-Editor ist eben kein vollwertiger Ersatz eines HTML-Design-Programms o.ä., vor allem nicht als Formatierungshilfe in einem Shop-System. Dort machen z.b. verschiedene Schriften in einzelnen Texten eigentlich keinen Sinn, sondern dies würde man besser einheitlich per CSS lösen, sei es global oder eben mit den Editor-Styles, die man ja selbst auch ändern und ergänzen kann bei Bedarf.
Trotzdem kann der CKEditor dies natürlich alles (schon immer), aber ich habe rein redaktionell entschieden, einige dieser Features per default auszublenden (da geben mir die meisten Kunden auch Recht). Man kann jedoch jederzeit per Moduloptionen den Editor auf den “Full”-Modus setzen, dann werden auch alle verfügbaren Buttons eingeblendet, wenn man es denn wirklich braucht… :slight_smile:

beste Grüße vom Mitmacher
(falls dir die Antwort nicht hilft und/oder das Problem evtl. anders gelagert ist, dann bitte am besten per PM/Mail.)

PS: was ist denn das plötzlich für ein Quatsch mit diesem nervigen Re-Captcha hier im Forum??? Ich bin doch bereits eingeloggt und hasse diese Google-Gimmicks! :eek:


#91

Hallo Mitmacher,

[QUOTE=Mitmacher;177201]
PS: was ist denn das plötzlich für ein Quatsch mit diesem nervigen Re-Captcha hier im Forum??? Ich bin doch bereits eingeloggt und hasse diese Google-Gimmicks![/QUOTE]

Ein vorübergehender Spamfight nachdem die Mods nächtelang gesessen und Müll aus dem Forum geschoben haben.

Gruß


#92

Hi Marco! Danke + sorry für meinen Gefühlsausbruch, aber da ich erst im 10. Versuch oder so endlich speichern konnte (FF-noscript-user), war ich doch genervt. “vorübergehender Spamfight” klingt plausibel (mein mitleid an die mods!) aber macht auch Hoffnung, denn captcha bei jedem Beitrag wäre keine gute dauerlösung (sehr vorsichtig ausgedrückt). Toi toi, dass ihr es anders in den Griff bekommt, shice spammer!


#93

An dem Modul sind wir auch sehr interessiert, haben jedoch vor dem Kauf eine Frage:
Der Shop, an dem wir gerade arbeiten, hat nicht nur ein Beschreibungstext bei Produkten, sondern mehrere. Das heißt, die Datenbank wurde dahingehend erweitert, dass es mehrere Felder für ausführliche Beschreibungen gibt und diese im Admin bearbeitet werden können.
Bietet das Modul die Möglichkeit, solche eigenen Felder, die also manuell in den Administrationsbereich eingefügt wurden, ebenfalls mit dem CKEditor zu nutzen, oder kann das Modul das nicht?


#94

Hallo und danke für das Interesse!
Ich sage spontan einfach mal ja, auch dies ist mit dem Modul möglich und wird auch bereits mehrfach so genutzt. Es hängt evtl. etwas davon ab, wie diese zusätzlichen Felder umgesetzt wurden, aber wenn die OXID-Konventionen eingehalten wurden, sollte es keinerlei Problem sein (es gibt extra eine Moduloption für weitere Textfelder).
Ich biete in solchen Fällen auch gerne eine Testversion an, dazu kommt gleich noch eine PM hinterher… :slight_smile:
Beste Grüße!


#95

Unser Kunde möchte gern eigene Styles in dem Stil-Dropdown hinzugefügt haben, doch egal was wir tun (Definition eines eigenen Styles in der Datei admin/ckeditor/custom/styles.js; Definition eines Styles direkt in der Datei admin/ckeditor/config.js; ändern des Standard-Styles), nichts hat eine Auswirkung auf die Darstellung des Inhalts des Dropdowns und genauso gibt es auch überhaupt keine Änderung in der Auswahl der gezeigten Editorelemente, wenn z.B. in der Basic Toolbar etwas aus der Config gelöscht wird.
Nach Änderung in der config.js haben wir sowohl den Cache geleert, das Modul deaktiviert und wieder aktiviert, alles keine Auswirkungen.

Was machen wir falsch?


#96

Hoppla, da nutzt noch wer mein gutes altes Modul, da hätte ich schon fast nicht mehr mit gerechnet (scheinbar wg. Summernote, keine Ahnung)! :wink:
Also bin ich wohl am ehesten gefragt, obwohl es eigentlich nicht das Modul betrifft, und die CKE-Dokus sind ja durchaus gut und brauchbar. Ich habe das auch selbst seit Jahren nicht mehr gebraucht mit den Styles, ich weiß aber, dass es definitiv funktionerte. Und die Änderungen an den Editorelementen so und so. Was meinstes du denn mit “Cache”? Falls nämlich das OXID-tmp-Dir, dann könnte evtl. dort der Hund begraben liegen. So weit ich weiß, ist nämlich das einzige was hilft, den Browser-Cache zu leeren, alles andere hat keine Relevanz. Ich habe es jedenfalls gerade nochmal schnell getestet und es funktioniert damit definitiv. Bitte nochmal selbst testen…