Images exist on the Server and in the Shop but are not displayed in the shop (Front of the Shop and Admin)


#1

Hi guys,

I have a connector that from ERP system is exporting products (with it’s images) into the oxid shop.
The product is created successfully and the images are generated in correct folders.
ex. out/pictures/generated/product/5/540_340_75/image_name_1.jpg

In the front of the shop, for the same product, also ‘nopic’ image is only displayed.

In Admin-Backend, for the product, in ‘Pictures’ tab, the images are there but not displayed. And when you are trying to open it in new tab, ‘nopic’ image is displayed with the following address:
www.shopname.com/out/pictures/generated/product/1/390_245_75/nopic.jpg

Also, when I am downloading the image from the server, it can be open and displayed properly. But if I open it forcibly in the browser, it’s not displayed properly. Only one small square is displayed.

I am using OXID 6.0.3 CE.

Thank you very much in advance!


#2

Hi,
do the folders in out/pictures have the correct permissions? Have you try to open the picture in your browser? So if that wont work it can be the owner settings. Sample like https://www.yourshop.com/out/pictures/product/1/390_245_75/yourPictureName.jpg

Another point can be a defined $this->altImageDir configuration in the config.inc.php.

Greets
Andi


#3

Hello,

All the folders have permissions 777.

Yes I tried to open the image via browser like:
https://www.yourshop.com/out/pictures/generated/product/5/540_340_75/yourPictureName.jpg but without success, only black small square is displayed.
But as I mentioned above, if I download the image via filezila, it can be open properly.

This line you mentioned: $this->altImageDir doesn’t exist in the config.inc.php so should I add it and set to true or ?

Thanks a lot!


#4

I think you have to check the owner settings of the files. Please upload one picture from the admin and compare this. Another question: Not only the Folders have 777, the images need it too.

If $this->altImagedir doesn´t exist, this is not the problem :wink:


#5

I changed permission of the images into the directory, and now the image can be accessed via URL, but are still not assigned for the product and in admin-backend and also in the front of the shop, still ‘no pic’ image is displayed but in the admin, the images are there for the product as you can see from my screenshot in my first post…