I just wanted to update from CE 6.2.2 to CE 6.2.3. oxideshop-ide-helper blocked the update.
I excluded it form composer.json (deleted the entry) and everything worked fine. But I might need to update this file in the future.
Apparently oxideshop-ide-helper does support only Composer 1 (see error-message).
So could you please add Composer 2 support for this file?
- Root composer.json requires oxid-esales/oxideshop-ide-helper ^v3.1.2 -> satisfiable by oxid-esales/oxideshop-ide-helper[v3.1.2].
- oxid-esales/oxideshop-ide-helper v3.1.2 requires composer-plugin-api ^1.1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint.
You are using Composer 2, which some of your plugins seem to be incompatible with. Make sure you update your plugins or report a plugin-issue to ask them to support Composer 2.
Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.