Spamuser Einträge über Nacht

Wer hat das auch, seit wenigen Tagen werden über Nacht massenweise Spamuser Einträge erstellt. Vermute mal es betrifft nur alte Versionen, würd aber gern hier mal horschen wers noch hat.

Ich hatte vor ca einer Woche so einen Eintrag. Habe mir aber nichts dabei gedacht, da es (einmalig) auch ein Mensch sein könnte.

Bei mir kommt mehr Spam über den Blog.

will dir ja nicht unnötig angst machen, aber ich würd mal schauen ob die nicht versucht haben irgendwas anzugreifen und eventuell sogar erfolgreich waren. spamregistrierungen nur der registrierung wegen sind eher selten, wenn dann haben die damit was vorgehabt.

Danke für Eure Antworten, zeigt es mir, daß NICHT NUR alte Versionen betroffen sind und klar, geprüft werden muß es, und wurde zwecks Prüfung auch gemeldet bei anzido.

die Einträge kommen von “Newsletteranmeldungen”, daher halte ich es als “Pflicht”, daß Oxid hier für die Version 4 eine Nachbesserung vornimmt und ein Captcha Feld einfügt.

Wer trägt es bitte mal in Bugtrack ein ??

die Einträge kommen von “Newsletteranmeldungen”, daher halte ich es als “Pflicht”, daß Oxid hier für die Version 4 eine Nachbesserung vornimmt und ein Captcha Feld einfügt.

Ich persönlich halte captchas für kundenschreck nr. 1. die haben nix auf kommerziellen webseiten zu suchen. du erschwerst damit nämlich kunden genauso das registrieren wie den bots. Captchas sind erwiesenermaßen schädlich für den webseitenbetrieb, weil sie benutzer stören und oft auch nicht lesen können.

und was ist dann Dein Lösungsvorschlag - sollen die Shopbetreiber täglich im Admin 10-20-30-40-xxxx User löschen ??

Wie mir dieser Thread zeigt, betrifft es nicht “ein Leck” in den alten Versionen, sondern es wird auch in der 4er weiter diese doofen Einträge geben und auf löschen hab ich auch keine Lust, also was tun ??

Andererseits sollte man vielleicht überlegen, womit gewinnt man Newslettereinträge - wenn diese sowieso mehr aus dem “Bestellvorgang” hervorgehen, so ist der Anteil derer, die sich über den Newsletteranmeldeprozess anmelden schwindend gering und die dann dort sich anmelden wollen, glaube DIE geben auch die 5captcha-Buchstaben ein.

und was ist dann Dein Lösungsvorschlag - sollen die Shopbetreiber täglich im Admin 10-20-30-40-xxxx User löschen ??

Also soweit ich das hier verfolgt hab ist das bis jetzt einmal bei firefax vorgekommen und bei dir seit ner woche.

und ich hab grad mal ein paar der domains testweise überprüft, die gibts garnicht. der bug ist also kein fehlendes captcha, sondern eine fehlende validierung ob es die domain zur emailadresse überhaupt gibt. und die fehlt genauso im 4er, weil ich mich mit einer [email protected] adresse grade erfolgreich für den newsletter im demoshop hab anmelden können.

also vielleicht erstmal die validierung hinzufügen. ist eine einzige php funktion die man da aufrufen muss.

Womit ich sehr gute Erfahrunbgengen gemacht hab statt Captchar sind Klartextfragen in Landessprache. 10-15 Fragen hinterlegen und bei den Antworten die gängisten Schreibfehler berücksichtigen, das sollte gut dicht machen. Das als Modul umzustezen sollte auch nicht so ein riesen Aufwand sein.

Aber klar: die Validierung muss auch stimmen aber: @csimon: deine test-mailadresse ist syntaktisch schon korrekt…
Welche weiteren Möglichkeiten wären da noch? die Domain prüfen mittels DNS Validierung, MX Rwcord prüfen.
SMTP Validierung einzusetzen, das kann ganz schöne Latzenzzeiten hervorufen und wegen “catch all” Adressen ist das dann auch nicht 100%tig, die Spamer sind da doch erstaunlich gut :wink:

Viele Grüße

Magnus

[QUOTE=csimon;28764]also vielleicht erstmal die validierung hinzufügen. ist eine einzige php funktion die man da aufrufen muss.[/QUOTE]
Wobei sich jeder Robot mittlerweile über das OXID Captcha schlapplachen dürfte…

Diese Grafik entschlüsseln die “Mit Links”…

die Domain prüfen mittels DNS Validierung, MX Rwcord prüfen.
SMTP Validierung einzusetzen, das kann ganz schöne Latzenzzeiten hervorufen und wegen “catch all” Adressen ist das dann auch nicht 100%tig, die Spamer sind da doch erstaunlich gut :wink:

Eine DNS Prüfung hätte hier sämtliche einträge abgewehrt. ich meinte natürlich eine dns prüfung. die verursacht nun auch nicht so große latenzen, und wenn dann sind die bei einer newsletteranmeldung zu verkraften :wink:

Diese Grafik entschlüsseln die “Mit Links”…

Richtig, und je schwerer man es den robots macht, desto schwerer macht mans dem endkunden.

Nachdem bis gestern Abend 20.00 Uhr Ruhe war, kam es seitdem zu knapp 50 Newsletteranmeldungen von SpamUsern. :frowning:

Als Notlösung habe ich mal das E-Mailfeld der Newsletteranmeldung auf der Startseite deaktiviert. Ob es das Problem reduziert kann ich noch nicht sagen.

Gab es eigentlich schon eine praktikablen Lösungsansatz nach der Diskussion hier für das Problem ?

[QUOTE=Firefax;30003]Als Notlösung habe ich mal das E-Mailfeld der Newsletteranmeldung auf der Startseite deaktiviert. Ob es das Problem reduziert kann ich noch nicht sagen. [/QUOTE]
Das wird Dir wohl nix nützen…

Denn die Robots “POSTEN” die notwendigen Daten ja vermutlich direkt zu dem Shop-Programm, und füllen nicht das Formular aus.

[QUOTE=avenger;30004]Das wird Dir wohl nix nützen…

Denn die Robots “POSTEN” die notwendigen Daten ja vermutlich direkt zu dem Shop-Programm, und füllen nicht das Formular aus.[/QUOTE]

Stimmt, auf jeden Fall gehen die Einträge weiter. Da ja auch der Name ausgefüllt wird kann es ja erstmal nichts mit dem Newsletter-Link auf der Startseite zu tun habe.

Ich habe nun die /tpl/newsletter.tpl deaktiviert / geändert, so das keine Möglichkeit mehr besteht sich hier für einen Newsletter einzutragen. Bin mal gespannt ob die Einträge jetzt aufhören.

Und so etwas Samstag abends und Sonntag :mad:
CYA

[QUOTE=Firefax;30006]Ich habe nun die /tpl/newsletter.tpl deaktiviert / geändert, so das keine Möglichkeit mehr besteht sich hier für einen Newsletter einzutragen. Bin mal gespannt ob die Einträge jetzt aufhören.[/QUOTE]
Nein, das wird aus dem gleichen Grund nichts nützen…

Das kannst Du erst mal nur verhindern, wenn Du die “core/oxnewsletter.php” umbenennst…

http://www.oxidmodule.com/OXID-Community-4/deaktivierte-Newsletteranmeldung.html

gibts von d3 ein kostenloses modul für.

[QUOTE=csimon;30008]http://www.oxidmodule.com/OXID-Community-4/deaktivierte-Newsletteranmeldung.html

gibts von d3 ein kostenloses modul für.[/QUOTE]

Das Modul macht etwas ganz anderes, es deaktiviert bei der Kontoerstellung das voreingestellte aktivierte Häckchen. Darüber hinaus prüft es ob ein Newslettereintrag vorliegt, damit das Häckchen dann vor ausgefüllt ist. Es gibt RA die permanent vorausgefüllte Häckchen bei der Kontoerstellung (wie im Standard) bemängeln.
Das Modul habe ich darüber hinaus schon am laufen. Das macht den Shop rechts-sicherer.

Danke an D3 für das super Modul.

Zu den SpamUsereinträgen:
Problem gelöst, Patient halbtot im Koma. :o

Seitdem ich die /tpl/newsletter.tpl geändert (quasi gelöscht) habe hatte ich keine SpamUsereinträge mehr (schon seit 2h). Die scheinen doch über www. meinshop. de/newsletter gekommen zu sein. Die Lösung ist zwar nicht gut, aber der Spam ist weg und ich kann den Shop nun bis Montag so weiterlaufen lassen.
Wenn mir nichts besseres einfällt spiele ich morgen die newsletter.tpl wieder richtig ein und hoffe das der Spam-Bot weitergezogen ist.

CYA

ach ich dachte damit könnte man auch die komplette komponente überschreiben.

Naja, geht aber auch so mit nem minimodul:


class blockNewsletter_newsletter extends blockNewsletter_newsletter_parent {
    public function send() {
          // keine anmeldung mehr
          $this->_aViewData['msgNewsletterBlocked'] = 'Die Newsletteranmeldung ist momentan leider nicht möglich';
    }
}

und ins template dann:


[{ if $msgNewsletterBlocked}]
    [{$msgNewsletterBlocked}]
[{ /if }]

das einfach in den modulordner kopieren, pfad ist beliebig und das modul so ungefähr einbinden:

newsletter => blockNewsletter/blockNewsletter_newsletter.

habs jetzt nicht getestet, sollte aber abhilfe schaffen ohne die templates löschen zu müssen. den smarty code kann man ruhig immer im template lassen.

Ok, Danke für das Modul, grundsätzlich verstehe ich das Modul auch. Ich bleibe aber lieber dabei die tpl anzupassen. Ist zwar etwas dirty, aber da weiß ich wenigstens was ich mache :wink:

Status:
Im Laufe des Tages habe ich das original newsletter.tpl wieder eingebaut und seitdem keine Spameinträge mehr. Der Spambot scheint sich vorläufig verzogen zu haben. Hoffentlich bleibt das so.

Wer Ihn nun hat kann sich ja melden. :eek:

CYA

Ich habe seit 3 Tagen einen Spam-Bot am Hals, der täglich so um die 30-50 Kundenregistrierungen durchführt.

Dem könnte ich nur durch ein Captcha in der Registrierung bei kommen (will ich aber nicht einbauen).

Die Registrierungen sind alle nach einem ähnlichen Muster aufgebaut:

[B]diverse E-Mail-Adressen[/B] - wobei eine Validierung nichts bringen würde, da die Domains zum größten Teil existieren.
[B]Straße:[/B] The Five Street
[B]Ort:[/B] NewYork

Möglicherweise würde eine Validierung auf den Ort ja etwas bringen … aber was baut man da an welcher Stelle im Code ein?

Es wäre toll, wenn jemand einen Tipp für mich hätte, da ich momentan täglich die entsprechenden Benutzer lösche und nicht genau abschätzen kann, was der Quatsch überhaupt soll …

Für Eure Hilfe bedanke ich mich schon mal im Voraus.